Pfft, you don't even need PSO2es