Mega tells me that I am using an outdated browser (Firefox 18.0.1) #firefox