NetBSD/hpcarm 6.0 + pkgsrc-2012Q3 でも以前のパッチのままで xclannad 起動した。なー。gcc-4.1.3 がアレだったということか……